Some PayNow charges processing fails
Incident Report for Opn Payments
Resolved
We experienced an internal technical issue which had resulted in PayNow on Fri 3 Feb, during which, some PayNow transactions failed.

Our teams had investigated and rectified the issue right away. All services were back to normal.

We apologize for the inconvenience this has caused. For questions or concerns regarding this incident, please reach out to support@opn.ooo

Opn Payments
Posted Feb 03, 2023 - 17:59 GMT+07:00
Investigating
We are currently experiencing degraded performance issues with PayNow processing. Our team is currently working to restore normal performance levels.

Updates will be provided on https://status.omise.co. We apologize for any inconvenience caused.

Opn Payments
Posted Feb 03, 2023 - 11:06 GMT+07:00
This incident affected: Alternative Payments (Paynow (SG)).