Singapore Paynow charges are failling
Incident Report for Omise
Resolved
This incident has been resolved.
Posted Jul 19, 2021 - 14:18 GMT+07:00
Update
The incidents has been resolved
Posted Jul 19, 2021 - 14:17 GMT+07:00
Investigating
We are currently investigate the issue
Posted Jul 19, 2021 - 09:44 GMT+07:00
This incident affected: Alternative Payments (Paynow (SG)) and API (Global).