We experienced a technical issue which had resulted in the 3DS service between Tuesday, 30th September 18:30 to Wednesday, 1st October 17:53 (GMT+8), during which, some 3DS credit card charges failed.
Our teams had investigated and informed our acquiring partner to rectify the issue immediately. The credit card service is now fully operating as normal.
We sincerely apologize for any inconvenience this may have caused. For questions or concerns regarding this incident, please reach out to support@omise.co
Omise Payments
Posted Oct 01, 2025 - 17:44 GMT+07:00
Investigating
We are currently investigating a technical issue affecting 3DS authentication for credit card payments, which began on Tuesday, 30th September at 18:30 (GMT+8).
This may be impacting some Malaysia-based merchants, where certain 3DS charges may be failing during this time.
Our team is actively working to identify the root cause and resolve the issue as soon as possible. We will share updates as they become available.
We apologize for the inconvenience this may be causing. For any questions or concerns, please contact us at support@omise.co.
Omise
Posted Oct 01, 2025 - 10:20 GMT+07:00
This incident affected: Credit / Debit cards (Global).