[Partner] Kasikorn Debit Card will be unavailable on Thu, Mar 26 03:00-03:15 (GMT+7)

Scheduled for Mar 26, 03:00 - 03:15 GMT+07:00

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 24, 2026 - 12:49 GMT+07:00

Scheduled

Kasikorn Debit Card will be unavailable on Thu, Mar 26 03:00-03:15 (GMT+7)
Posted Mar 24, 2026 - 09:25 GMT+07:00
This scheduled maintenance affects: Debit cards (TH) (Kasikorn Bank (TH)).